New update for Extended Useradmininfo available - Take a look at this post for more informations!
The GeoIP API will be disabled on December 31, 2017! Please make sure you update your plugin until this date!


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
5 - Solved Error calling API - no suitable wrapper could be found
#1
Bug 
I get this error if i am on a users profile:

Quote:[size=x-small]File[/size]
[size=x-small]Line[/size]
[size=x-small]Function[/size][size=x-small][PHP][/size]
[size=x-small] [/size]
[size=x-small]errorHandler->error[/size]
[size=x-small]/inc/functions_extendeduseradmininfos.php[/size]
[size=x-small]114[/size]
[size=x-small]file_get_contents[/size]
[size=x-small]/inc/plugins/extendeduseradmininfos.php[/size]
[size=x-small]275[/size]
[size=x-small]getGeoInformations[/size]
[size=x-small]/inc/class_plugins.php[/size]
[size=x-small]139[/size]
[size=x-small]extendeduseradmininfos_get_info[/size]
[size=x-small]/member.php[/size]
[size=x-small]1944[/size]
[size=x-small]pluginSystem->run_hooks[/size]

[size=small]Warning[/size] [2] file_get_contents(https://florian-berger.info/geoip/api.php?ip=*Censored IP*): failed to open stream: no suitable wrapper could be found - Line: 114 - File: inc/functions_extendeduseradmininfos.php PHP 7.0.23 (Linux)


[size=x-small]File[/size]
[size=x-small]Line[/size]
[size=x-small]Function[/size][size=x-small][PHP][/size]
[size=x-small] [/size]
[size=x-small]errorHandler->error[/size]
[size=x-small]/inc/functions_extendeduseradmininfos.php[/size]
[size=x-small]114[/size]
[size=x-small]file_get_contents[/size]
[size=x-small]/inc/plugins/extendeduseradmininfos.php[/size]
[size=x-small]275[/size]
[size=x-small]getGeoInformations[/size]
[size=x-small]/inc/class_plugins.php[/size]
[size=x-small]139[/size]
[size=x-small]extendeduseradmininfos_get_info[/size]
[size=x-small]/member.php[/size]
[size=x-small]1944[/size]
[size=x-small]pluginSystem->run_hooks[/size]
Reply
#2
Hello,

thanks for your report. It seems that the option allow_url_fopen is disabled in your php.ini file. Please make sure it is enabled.

If you have no access to this file, ask your hoster for activation.
Reply
#3
Hey, it was enabled all the time.
Reply
#4
Well, the error says different. Smile

Four days ago I uploaded a new version of the plugin. This will no longer use the API on my server, so the file_get_contents is not used. Please take a look at this post for more informations about the update.
Reply
#5
I found the problem.
allow_url_fopen is only active in the main directory (how is this possible??)
My forum is on a sub directory (/forum) and there it doesn't work.
Ive contacted my hoster.

Thanks for your help
Reply


[-]
Quick Reply
Message
Type your reply to this message here.

Human Verification
Please tick the checkbox that you see below. This process is used to prevent automated spam bots.

Forum Jump:


Users browsing this thread: 1 Guest(s)